WPSSO FAQ Manager

FYI

  • Plugin Name: WPSSO FAQ Manager
  • Stable Version: 2.0.0
  • Author: JS Morisset
  • Description: Manages Question / Answer pages and FAQ categories, along with offering shortcodes to include FAQs in your content.
  • License: GPLv3
  • Requires PHP: 5.5 or newer
  • Requires WordPress: 4.0 or newer
  • Tested Up To WordPress: 5.3.2
  • Last Updated: 4 hours ago
  • Plugin Homepage »

Version Numbering

Version components: {major}.{minor}.{bugfix}[-{stage}.{level}]

  • {major} = Major structural code changes / re-writes or incompatible API changes.
  • {minor} = New functionality was added or improved in a backwards-compatible manner.
  • {bugfix} = Backwards-compatible bug fixes or small improvements.
  • {stage}.{level} = Pre-production release: dev < a (alpha) < b (beta) < rc (release candidate).

Standard Version Repositories

Changelog / Release Notes

Version 2.0.0 (2019/12/11)

  • New Features
    • Added a [faq] shortcode to include a FAQ category in post/page content.
    • Added a [question] shortcode to include individual Questions in post/page content.
  • Improvements
    • Added a "Shortcode" column to the "All Questions" and FAQ "Category" lists.
  • Bugfixes
    • None.
  • Developer Notes
    • Added new library files:
      • lib/post.php
      • lib/style.php
      • lib/term.php
      • lib/shortcode/faq.php
      • lib/shortcode/question.php
    • Added new hard-coded / fixed constants:
      • WPSSOFAQ_CATEGORY_TAXONOMY = 'faq_category'
      • WPSSOFAQ_QUESTION_POST_TYPE = 'question'
    • Added new variable constants:
      • WPSSOFAQ_FAQ_SHORTCODE_NAME = 'faq'
      • WPSSOFAQ_QUESTION_SHORTCODE_NAME = 'question'
  • Requires At Least
    • PHP v5.5.
    • WordPress v4.0.
    • WPSSO Core v6.16.2.

Version 1.1.0 (2019/12/08)

  • New Features
    • None.
  • Improvements
    • Added a flush_rewrite_rules() function call on plugin activation / deactivation to refresh the 'faq_category' taxonomy and 'question' post type URLs.
  • Bugfixes
    • None.
  • Developer Notes
    • None.
  • Requires At Least
    • PHP v5.5.
    • WordPress v4.0.
    • WPSSO Core v6.15.0.