WPSSO – Product Condition and WP / PHP Versions

WPSSO v3.40.3-1 plugin has been released (see the complete Changelog here) — this new version adds a custom “Product Condition” option in the Social Settings metabox, along with updating the minimum & recommended versions for WordPress and PHP.

The new “Product Condition” option will be visible only if the Open Graph og:type meta tag value is a “product” — which is the default value for all product pages from Easy Digital Downloads, MarketPress – WordPress eCommerce, WooCommerce, WP eCommerce, and most other e-commerce plugins (developers can also hook the ‘wpsso_og_type’ filter to change the default value – see the complete list of filters here).

WordPress.org does not support versions older than the current v4.7.3 production release — and v3.7 onwards may or may not get security updates, depending on the severity. The minimum & recommended versions supported by WPSSO have been revised to reflect this information — WPSSO will not activate if you are using a WordPress version older than v3.7, and will show a dismissable notice to recommend upgrading if you are using a version older than v4.7.3.

Also, PHP versions older than v5.6 are no longer supported and do not receive any security updates. The minimum & recommended versions supported by WPSSO have been revised to reflect this information — WPSSO will not activate if you are using a PHP version older than v5.3, and will show a dismissable notice to recommend upgrading if you are using a version older than v5.6. Over the next several releases of WPSSO, these minimum & recommended version numbers will be increased to v5.6 & v7.0. If you’re not already using PHP v7.0, I recommend you contact your hosting provider to have them update your site (almost all hosting providers now support PHP v7.0 or v7.1).

Have you rated the WPSSO plugin yet?

Please encourage us by rating the WPSSO plugin on wordpress.org. When we hear that you appreciate the plugin and its features, it encourages us to keep working on those features for you!

Improve stability by testing pre-release versions!

WPSSO Pro users have the option of updating to Development and Pre-release versions — if you have a Development or QA website (for example), you can test upcoming releases by selecting a pre-production stage under the SSO > Update Manager settings page. Developments sites also have access to a Free developer license, provided you use a specific WordPress Site Address (URL) value for your development site.

Thanks for reading, and enjoy the plugins! ;-)

js.